QPR UI System Requirements

From QPR ProcessAnalyzer Wiki
Jump to: navigation, search

This page contains all QPR UI system requirements for both the server environment and client devices running web browsers.

Client Devices

The following client devices and web browsers are supported:

  • Windows desktop
    • Google Chrome
    • Firefox
    • Internet Explorer 11
  • Mac desktop
    • Safari
  • Tablets and smartphones
    • Apple iPad and iPhone with iOS 12 and Safari
    • Android versions 5.0 - 7.1.2 with Chrome for Android

Note: Due to the rapid update schedule of web browsers, QPR Software does not specify the supported versions but indicates the latest versions that are tested and verified to work. Firefox and Chrome versions newer than the tested versions are likely to work normally, but QPR Software cannot guarantee their functionality before the next QPR UI release. Any compatibility issues will be fixed as soon as possible for the next release.

Database Systems and Database Configuration

Microsoft SQL Server 2012, 2014, 2016 and 2017 are supported. In addition, the following configurations are required in the SQL Server:

More information about SQL Server configuration for QPR UI.

Server Operating Systems

  • Windows 10
  • Windows 8.1 / Windows 8
  • Windows 7 (only SP1)
  • Windows 2012 Server R2 / Windows 2012 Server
  • Windows 2008 Server R2 / Windows 2008 Server

QPR ProcessAnalyzer Server

If QPR UI is connected to a QPR ProcessAnalyzer Server (using the PA_SERVICE_LOCATION system setting), the QPR ProcessAnalyzer Server must be the same version as QPR UI (the two leftmost numbers in the version needs to match, for example 2018.1.1 and 2018.2.1 are not compatible with each other, but 2018.1.1 and 2018.1.2 are compatible).

Other Needed Server Components

The following components need to be installed before running QPR UI installer (as QPR UI installer does not install them):

The following components are needed by QPR UI, and QPR UI installer will install them automatically, if needed:

Security note: QPR UI installer won't install the latest update of Java 8. After the QPR UI installation, check the currently installed Java version from the About Java window, and compare it with the latest available version in the Java download site. If a newer version of Java is available, update it.

Note: QPR UI is not compatible with Java 9. If there is Java 9 installed in the server computer, please uninstall it before installing QPR UI.

Recommended Server Hardware

The following recommendations describe how much hardware is usually needed in the server for the QPR UI environment to run smoothly.

Minimum configuration:

  • 2GB memory
  • 20GB disk
  • 2 processor cores

Medium configuration:

  • 4GB memory
  • 30GB disk
  • 4 processor cores

Large configuration:

  • 6GB memory
  • 40GB disk
  • 8 processor cores