Difference between revisions of "QPR ProcessAnalyzer Version Compatibility"

From QPR ProcessAnalyzer Wiki
Jump to: navigation, search
 
Line 51: Line 51:
 
|style="width: 7%; text-align: center; background-color: white;"|
 
|style="width: 7%; text-align: center; background-color: white;"|
 
'''2019.6'''
 
'''2019.6'''
 +
|style="width: 7%; text-align: center; background-color: white;"|
 +
'''2019.7'''
 
|--
 
|--
 
|style="width: 20%; background-color: white;"|
 
|style="width: 20%; background-color: white;"|
 
Internal version
 
Internal version
|colspan="23" style="text-align: center; background-color: #eedfcc;"|
+
|colspan="24" style="text-align: center; background-color: #eedfcc;"|
 
6
 
6
 
|-
 
|-
Line 69: Line 71:
 
|colspan="2" style="text-align: center; background-color: #eedfcc;"|
 
|colspan="2" style="text-align: center; background-color: #eedfcc;"|
 
59
 
59
 +
|colspan="1" style="text-align: center; background-color: #eedfcc;"|
 +
61
 
|-
 
|-
 
|style="width: 20%; background-color: white;"|
 
|style="width: 20%; background-color: white;"|
 
Stream version
 
Stream version
|colspan="23" style="text-align: center; background-color: #eedfcc;"|
+
|colspan="24" style="text-align: center; background-color: #eedfcc;"|
 
7  
 
7  
 
|-
 
|-
Line 78: Line 82:
 
|style="width: 10%; background-color: white;"|
 
|style="width: 10%; background-color: white;"|
 
Model compatibility version
 
Model compatibility version
|colspan="23" style="text-align: center; background-color: #eedfcc;"|
+
|colspan="24" style="text-align: center; background-color: #eedfcc;"|
 
2  
 
2  
 
|-
 
|-

Latest revision as of 09:19, 10 September 2019

Table below lists the compatibility between QPR ProcessAnalyzer releases.

Product release

2017.1

2017.2

2017.3

2017.4

2017.5

2017.6

2017.7

2017.8

2017.9

2018.1

2018.2

2018.3

2018.4

2018.5

2018.6

2018.7

2018.8

2019.1

2019.2

2019.3

2019.4

2019.5

2019.6

2019.7

Internal version

6

Database version

55

56

57

58

59

61

Stream version

7

Model compatibility version

2

Notes on Compatibility

Different QPR ProcessAnalyzer releases are compatible with each other according to the following principles:

  • Internal version defines the compatibility of the database schema. When using database connections (QPR ProcessAnalyzer Xpress or Database), a database can not be accessed with a client if it has been migrated using another client having a higher internal version than the current client. For example, if you have migrated the database to the 2015.5 release (i.e. internal version 5), it is still compatible with 2015.1 but if you have migrated the same database to 2016.1 (i.e. internal version 6), it will only work with 2016.1.
  • New database version is two-way compatible with the old version if the database version numbers match. When a new release is installed, then the database will be upgraded to the new database version.
  • Stream version affects the *.pacm model file compatibility. Model exported using a QPR ProcessAnalyzer version that has lower stream version than the target system, can be imported. However, model exported using a QPR ProcessAnalyzer version that has higher stream version than the target system, can't be imported.
  • QPR ProcessAnalyzer Excel Client connects to the same version only, so e.g. release 2015.2 clients only connect to release 2015.2 server. Multiple services need to be deployed in parallel to the same database to support multiple client versions simultaneously.
  • Models having a higher model compatibility version than the model compatibility version of the current client can not be accessed in any way by that client. Model compatibility version for a model is changed whenever a model has been changed in a way that is no longer supported by older client versions.